Cronos (CRO) Mainnet api does not have the latest blockchain data.
Incident Report for Ledger
Resolved
This incident has been resolved.
Posted Mar 14, 2024 - 16:28 CET
Investigating
We have detected an issue with fetching the latest blockchain data from Cronos (CRO) Mainnet. This is being investigated by the team.
Posted Mar 14, 2024 - 11:51 CET
This incident affected: Ledger Explorers (Cronos (CRO)).