Polygon (MATIC) Mainnet api does not have the latest blockchain data.
Incident Report for Ledger
Resolved
This incident has been resolved.
Posted Feb 02, 2024 - 02:42 CET
Investigating
We have detected an issue with fetching the latest blockchain data from Polygon (MATIC) Mainnet. This is being investigated by the team.
Posted Feb 02, 2024 - 02:05 CET
This incident affected: Ledger Explorers (Polygon (MATIC)).