Multisig Service – Service Unavailable

Incident Report for Ledger

Resolved

This incident has been resolved.
Posted Feb 11, 2026 - 10:01 CET

Monitoring

The issue affecting the Multisig service has been mitigated.
The service is now operating normally. We are continuing to monitor system stability.
Posted Feb 11, 2026 - 09:42 CET

Investigating

We are currently investigating an issue affecting the Multisig service.

Users may experience difficulties performing Multisig-related operations. Our engineering teams are actively working to identify the root cause and restore full functionality as quickly as possible.
We will provide further updates as more information becomes available.
Posted Feb 11, 2026 - 08:24 CET