Ethereum (ETH) Mainnet api does not have the latest blockchain data.
Incident Report for Ledger
Resolved
This incident has been resolved.
Posted Apr 10, 2024 - 16:06 CEST
Investigating
We have detected an issue with fetching the latest blockchain data from Ethereum (ETH) Mainnet. This is being investigated by the team.
Posted Apr 10, 2024 - 14:58 CEST
This incident affected: Ledger Explorers (Ethereum (ETH)).