Polkadot (DOT) Mainnet Service Disruption

Incident Report for Ledger

Resolved

This incident has been resolved.
Fixes for both Ledger Live Desktop and Mobile have been successfully delivered.
Polkadot (DOT) Swap has been re-enabled.
Posted Apr 03, 2026 - 09:52 CEST

Update

A fix for Ledger Live Mobile has now been successfully delivered to address Polkadot connectivity issues. We are completing the final service validation. Users can manage their DOT transactions via the Desktop application. For urgent transactions, please refer to this article for alternative methods.
Posted Mar 31, 2026 - 13:59 CEST

Update

Update - We have successfully released a fix for Ledger Live Desktop to address the Polkadot connectivity issues. We are currently in the final stages of preparing a fix for the Ledger Live Mobile app, with an ETA for release this week. Now users can manage their DOT transactions via the Desktop application. For urgent transactions, please refer to this article for alternative methods.
Posted Mar 23, 2026 - 09:40 CET

Investigating

We are experiencing technical issues with the Polkadot (DOT) Mainnet within Ledger Wallet. As a precautionary measure, Polkadot (DOT) Swap has been temporarily disabled. DOT swap transactions are not available at this time and cannot be processed. Our team is actively working to resolve the issue. For urgent transactions, please refer to this article for alternative methods.
Posted Feb 23, 2026 - 14:45 CET
This incident affected: Ledger Explorers (Polkadot (DOT)).