Sui (SUI) Mainnet Network Outage

Incident Report for Ledger

Resolved

This incident has been resolved.
Posted Jan 14, 2026 - 22:33 CET

Monitoring

The Sui team has confirmed that a fix has been deployed.
We are currently monitoring the Sui (SUI) network to ensure recovery and stability.
As a reference, please see: Sui Status
Posted Jan 14, 2026 - 21:56 CET

Identified

The SUI network is currently experiencing a network outage. The Sui team is actively working to resolve the issue.
This may impact your ability to send transactions, add accounts, and view balances or transaction history.
As a reference, please see: Sui Status
Posted Jan 14, 2026 - 20:23 CET
This incident affected: Ledger Explorers (Sui (SUI)).