Swap: Changelly and CIC are down

Incident Report for Ledger

Resolved

This incident has been resolved. Swapping services with Changelly and CIC has resumed.
Posted Mar 12, 2024 - 22:15 CET

Update

We are continuing to investigate this issue.
Posted Mar 12, 2024 - 17:54 CET

Investigating

Swap services by Changelly and CIC are down. We are investigating with our partners. Apologies for any inconvenience.
Posted Mar 12, 2024 - 17:40 CET