Cosmos (ATOM) explorer does not have latest blockchain data
Incident Report for Ledger
Resolved
This incident has been resolved.
Posted May 17, 2023 - 18:12 CEST
Investigating
We have detected a problem with getting latest blockchain data from Cosmos (ATOM) explorer. This is being investigated by the team.
Posted May 17, 2023 - 18:12 CEST
This incident affected: Ledger Explorers (Cosmos (ATOM)).