Service Ledger Quest is down.

Incident Report for Ledger

Resolved

This incident has been resolved.
Posted Sep 14, 2023 - 15:57 CEST

Investigating

We have detected an issue with Ledger services for service Ledger Quest. This is being investigated by the team.
Posted Sep 14, 2023 - 15:54 CEST
This incident affected: Ledger Quest.