ALGO Explorer API Latency is critical.
Incident Report for Ledger
Resolved
This incident has been resolved.
Posted Nov 17, 2020 - 18:29 CET
Investigating
ALGO Explorer API Latency is critical.
Posted Nov 17, 2020 - 18:20 CET
This incident affected: Ledger Explorers (Algorand (ALGO)).