BCH Explorer API Latency is critical.
Incident Report for Ledger
Resolved
This incident has been resolved.
Posted Apr 02, 2021 - 18:45 CEST
Investigating
BCH Explorer API Latency is critical.
Posted Apr 02, 2021 - 18:42 CEST
This incident affected: Ledger Explorers (Bitcoin Cash (BCH)).