"Explorer ATOM" is down
Incident Report for Ledger
Resolved
This incident has been resolved.
Posted Feb 25, 2021 - 14:07 CET
Investigating
Error code HTTP 503 - Service Unavailable
Posted Feb 25, 2021 - 14:04 CET
This incident affected: Ledger Explorers (Cosmos (ATOM)).