"Explorer ZCASH" is down
Incident Report for Ledger
Resolved
This incident has been resolved.
Posted Sep 16, 2020 - 07:34 CEST
Investigating
Error code HTTP 503 - Service Unavailable
Posted Sep 16, 2020 - 05:22 CEST
This incident affected: Ledger Explorers (Zcash (ZEC)).