XTZ Explorer API Latency is critical.
Incident Report for Ledger
Resolved
This incident has been resolved.
Posted Nov 08, 2021 - 10:24 CET
Investigating
XTZ Explorer API Latency is critical.
Posted Nov 08, 2021 - 10:22 CET
This incident affected: Ledger Explorers (Tezos (XTZ)).