AppStore API Latency is critical.
Incident Report for Ledger
Resolved
This incident has been resolved.
Posted Jul 27, 2020 - 17:52 CEST
Investigating
AppStore API Latency is critical.
Posted Jul 27, 2020 - 17:46 CEST
This incident affected: Ledger Live Manager (Ledger Application Store).