XTZ explorer API has elevated error rates.
Incident Report for Ledger
Resolved
This incident has been resolved.
Posted Jun 16, 2022 - 20:12 CEST
Investigating
XTZ explorer API test has failures detected. We are checking this incident.
Posted Jun 16, 2022 - 20:10 CEST
This incident affected: Ledger Explorers (Tezos (XTZ)).