BNB explorer does not have latest blockchain data

Incident Report for Ledger

Resolved

This incident has been resolved.
Posted Nov 24, 2022 - 16:58 CET

Investigating

We have detected a problem with getting latest blockchain data from BNB explorer. We are checking this incident.
Posted Nov 24, 2022 - 14:12 CET
This incident affected: Ledger Explorers (Binance (BNB)).