DGB Explorer API Latency is critical.
Incident Report for Ledger
Resolved
This incident has been resolved.
Posted Nov 19, 2020 - 00:23 CET
Investigating
DGB Explorer API Latency is very high.
Posted Nov 19, 2020 - 00:20 CET
This incident affected: Ledger Explorers (Digibyte (DGB)).