Incorrect countervalues
Incident Report for Ledger
Resolved
This incident has been resolved.
Posted May 26, 2021 - 11:55 CEST
Investigating
The fiat value of your crypto in Ledger Live may be incorrect. We're working on fixing this as quickly as possible.
Posted May 26, 2021 - 10:03 CEST
This incident affected: Countervalue API.