"Explorer SOL" is down
Incident Report for Ledger
Resolved
This incident has been resolved.
Posted Aug 03, 2022 - 17:20 CEST
Investigating
Error code HTTP 503 - Service Unavailable
Posted Aug 03, 2022 - 16:03 CEST
This incident affected: Ledger Explorers (Solana (SOL)).