Degraded availability of some services due to Cloudflare outage

Incident Report for Ledger

Resolved

All impacted services have been restored, and our teams continue to monitor system performance to ensure stability.
Posted Nov 18, 2025 - 18:16 CET

Update

Cloudflare informs they have identified a fix for the issue and are working on restoring service.
Posted Nov 18, 2025 - 14:56 CET

Update

We are continuing to investigate this issue.
Posted Nov 18, 2025 - 13:54 CET

Investigating

Cloudflare has reported a partial outage starting November 18, 2025, 12:48 PM CET, causing widespread 500 errors, as well as Cloudflare Dashboard and API failures. For the latest updates, see the Cloudflare Status page.

As a result, some users may experience issues accessing certain Ledger services. We are actively monitoring updates from Cloudflare and working to resolve the issue.

Impacted Services:
- Ledger.com
- My Order, Affiliate Portal, Privacy Requests and Referral Program pages
- NFT metadata
- Transaction checks

Impacted Coins:
EGLD, ADA, ICX, FIL, KAS, OSMO, STX, MINA, ICP

Impacted Swap Providers:
Thorchain, NearIntents, Exodus, CIC, Changelly

Note: This list will be updated as more information becomes available.
Posted Nov 18, 2025 - 12:48 CET
This incident affected: Ledger Explorers (Cardano (ADA), Casper (CSPR), Cosmos (ATOM), Elrond (EGLD), Filecoin (FIL), Internet Computer (ICP), Icon (ICX), Mina (MINA), Stacks (STX)) and NFT Metadata Service, Ledger Website.