ETH explorer API has elevated error rates.
Incident Report for Ledger
Resolved
This incident has been resolved.
Posted Dec 10, 2021 - 23:07 CET
Update
ETH Explorers indexation process is blocked since 2021-12-10 13:42 UTC. This prevents seeing new transactions received or sent after the time and date mentioned. Balance updates happening after this time would not be reflected either. Investigation is ongoing. Rest assured this is purely issue to have updates to the balance and to the history of the transactions which has none impact on your assets.
Posted Dec 10, 2021 - 18:44 CET
Investigating
ETH explorer API test has failures detected. We are checking this incident.
Posted Dec 10, 2021 - 15:16 CET
This incident affected: Ledger Explorers (Ethereum (ETH)).