ETH explorer API has elevated error rates.
Incident Report for Ledger
Resolved
This incident has been resolved.
Posted Aug 18, 2021 - 08:21 CEST
Investigating
ETH explorer API test has failures detected. We are checking this incident.
Posted Aug 18, 2021 - 08:15 CEST
This incident affected: Ledger Explorers (Ethereum (ETH)).