DGB Explorer API Latency is critical.
Incident Report for Ledger
Resolved
This incident has been resolved.
Posted Jan 02, 2021 - 19:16 CET
Investigating
DGB Explorer API Latency is very high.
Posted Jan 02, 2021 - 19:12 CET
This incident affected: Ledger Explorers (Digibyte (DGB)).