Ledger Wallet Desktop and Mobile are temporarily down

Incident Report for Ledger

Resolved

This incident has been resolved.
Posted Apr 17, 2026 - 18:11 CEST

Update

We are continuing to investigate this issue.
Posted Apr 17, 2026 - 18:00 CEST

Investigating

We are experiencing technical issues with the Ledger Wallet Desktop and Mobile.
This may impact your ability to access the applications.
Our team is actively working to resolve the issue.
Posted Apr 17, 2026 - 17:59 CEST