BCH explorer API has elevated error rates.
Incident Report for Ledger
Resolved
This incident has been resolved.
Posted Jul 21, 2020 - 22:44 CEST
Investigating
BCH explorer API test has failures detected. We are checking this incident.
Posted Jul 21, 2020 - 22:38 CEST
This incident affected: Ledger Explorers (Bitcoin Cash (BCH)).