Digibyte (DGB) Mainnet api does not have the latest blockchain data.
Incident Report for Ledger
Resolved
This incident has been resolved.
Posted Apr 18, 2024 - 11:53 CEST
Investigating
We have detected an issue with fetching the latest blockchain data from Digibyte (DGB) Mainnet. This is being investigated by the team.
Posted Apr 17, 2024 - 16:19 CEST
This incident affected: Ledger Explorers (Digibyte (DGB)).