Service Loyalty Program is down.

Incident Report for Ledger

Resolved

This incident has been resolved.
Posted May 05, 2024 - 01:06 CEST

Investigating

We have detected an issue with service Loyalty Program. This is being investigated by the team.
Posted May 05, 2024 - 00:04 CEST
This incident affected: Loyalty Program.