Polkadot (DOT): new nominations are temporarily suspended
Incident Report for Ledger
Resolved
This incident has been resolved.
Posted Aug 25, 2021 - 09:31 CEST
Investigating
Attention Polkadot (DOT) users: new nominations are currently impossible in Ledger Live. As always, rest assured that your funds are safe.
More on this issue here:
https://support.ledger.com/hc/en-us/articles/360018131260-Earning-Polkadot-bonding-rewards?docs=true
Posted Aug 06, 2021 - 12:39 CEST