Polygon (MATIC) explorer does not have latest blockchain data
Incident Report for Ledger
Resolved
This incident has been resolved.
Posted Aug 31, 2023 - 23:43 CEST
Investigating
We have detected a problem with getting latest blockchain data from Polygon (MATIC) explorer. This is being investigated by the team.
Posted Aug 31, 2023 - 22:11 CEST
This incident affected: Ledger Explorers (Polygon (MATIC)).