Ethereum (ETH) explorer does not have latest blockchain data
Incident Report for Ledger
Resolved
This incident has been resolved.
Posted Aug 29, 2023 - 15:05 CEST
Investigating
We have detected a problem with getting latest blockchain data from Ethereum (ETH) explorer. This is being investigated by the team.
Posted Aug 29, 2023 - 14:44 CEST
This incident affected: Ledger Explorers (Ethereum (ETH)).