Horizen (ZEN) explorer does not have latest blockchain data
Incident Report for Ledger
Resolved
This incident has been resolved.
Posted May 23, 2023 - 11:18 CEST
Investigating
We have detected a problem with getting latest blockchain data from Horizen (ZEN) explorer. This is being investigated by the team.
Posted May 23, 2023 - 10:30 CEST
This incident affected: Ledger Explorers (Horizen (ZEN)).