XST Explorer API has elevated error rates.
Incident Report for Ledger
Resolved
This incident has been resolved.
Posted Sep 15, 2021 - 17:08 CEST
Investigating
XST Explorer API test has failures detected. We are checking this incident.
Posted Sep 15, 2021 - 16:51 CEST
This incident affected: Ledger Explorers (Stealthcoin (XST)).