DOT node does not have latest blockchain data
Incident Report for Ledger
Resolved
This incident has been resolved.
Posted Sep 20, 2022 - 08:28 CEST
Investigating
We have detected a problem with getting latest blockchain data from DOT node. We are checking this incident.
Posted Sep 20, 2022 - 08:28 CEST
This incident affected: Ledger Explorers (Polkadot (DOT)).