SOL Explorer API Latency is critical.

Incident Report for Ledger

Resolved

This incident has been resolved.
Posted Jun 21, 2022 - 08:59 CEST

Investigating

SOL Explorer API Latency is critical.
Posted Jun 21, 2022 - 08:57 CEST
This incident affected: Ledger Explorers (Solana (SOL)).