"Node DOT" is down
Incident Report for Ledger
Resolved
This incident has been resolved.
Posted Sep 14, 2021 - 17:34 CEST
Investigating
Error code HTTP 503 - Service Unavailable
Posted Sep 14, 2021 - 14:54 CEST
This incident affected: Ledger Explorers (Polkadot (DOT)).