XST Explorer API has elevated error rates.
Incident Report for Ledger
Resolved
This incident has been resolved.
Posted Nov 09, 2020 - 10:59 CET
Investigating
XST Explorer API test has failures detected. We are checking this incident.
Posted Nov 09, 2020 - 10:59 CET
This incident affected: Ledger Explorers (Stealthcoin (XST)).