Litecoin (LTC) Mainnet api 5xx response rate.
Incident Report for Ledger
Resolved
This incident has been resolved.
Posted Apr 17, 2024 - 11:00 CEST
Investigating
We have detected an issue with Ledger services for blockchain Litecoin (LTC) Mainnet. This is being investigated by the team.
Posted Apr 17, 2024 - 10:59 CEST
This incident affected: Ledger Explorers (Litecoin (LTC)).