MATIC Explorer does not have latest blockchain data
Incident Report for Ledger
Resolved
This incident has been resolved.
Posted Mar 24, 2023 - 13:33 CET
Investigating
We have detected a problem with getting latest blockchain data from MATIC Explorer. We are checking this incident.
Posted Mar 24, 2023 - 12:37 CET
This incident affected: Ledger Explorers (Polygon (MATIC)).