BTC Explorer API Latency is critical.
Incident Report for Ledger
Resolved
This incident has been resolved.
Posted Apr 21, 2021 - 11:01 CEST
Investigating
BTC Explorer API Latency is critical.
Posted Apr 21, 2021 - 11:01 CEST
This incident affected: Ledger Explorers (Bitcoin (BTC)).