Multiple services are degraded due to Cloudflare outage

Incident Report for Ledger

Resolved

Cloudflare has implemented a fix and services are coming back online. Internal recovery is progressing, and impacted Ledger services are returning to normal - total impact duration was 23 minutes. We continue to monitor stability.
Posted Dec 05, 2025 - 10:36 CET

Investigating

Cloudflare has reported an outage on December 5, 2025 09:56 AM CET, leading to services relying on Cloudflare APIs experiencing failed requests or errors. For the latest updates, see the Cloudflare Status page.

As a result, some users may experience issues accessing certain Ledger services. We are actively monitoring updates from Cloudflare and working to resolve the issue.

Impacted Services include:
Ledger Wallet
Ledger.com
Multisig
Posted Dec 05, 2025 - 10:25 CET
This incident affected: Ledger Wallet Manager (Ledger Application Store), Ledger Explorers (Aptos (APT), Casper (CSPR), Celo (CELO), Cosmos (ATOM), Cronos (CRO), Filecoin (FIL), Hedera (HBAR), Internet Computer (ICP), Near Protocol (NEAR), Ripple (XRP), Solana (SOL), Tezos (XTZ), Toncoin (TON), Vechain (VET)), and Buy, Earn Dashboard, Countervalue API, Crypto Assets Service, Cloud Sync, Swap API, Tezos Bakers API, NFT Metadata Service, Ledger Website, Ledger Quest, Loyalty Program.