Earn Dashboard - DeFi Positions Not Displayed (Kiln Provider Incident)

Incident Report for Ledger

Resolved

This incident has been resolved.
Posted Apr 03, 2026 - 12:22 CEST

Update

This incident has been resolved.
Posted Apr 03, 2026 - 12:20 CEST

Update

Following an additional fix deployed by Kiln, all operations are now restored, and Earn dashboard data is updating normally.
Posted Apr 03, 2026 - 11:10 CEST

Update

Kiln has reported their /defi/* endpoints are now operational.
We are currently verifying data consistency on our side, as some services may still experience delays while systems fully recover and resynchronize. Users may continue to see temporarily missing or outdated DeFi positions in the Earn dashboard during this period.
We will provide further updates once full data consistency is confirmed.
Posted Apr 02, 2026 - 18:00 CEST

Investigating

We are currently experiencing an issue affecting the Earn Dashboard where some users may see missing or outdated DeFi positions, particularly for Ethereum-based assets.
Our investigation has confirmed that this issue is caused by an incident on our staking infrastructure partner, Kiln, impacting their /defi/* API routes on Ethereum mainnet, see the Kiln Status Page.
As a result, DeFi positions (including Kiln-powered positions) may not be visible and Earn dashboard data may appear incomplete or stale.
The Kiln team has identified the issue and is currently working on restoring their services. We are actively monitoring the situation and will provide updates as soon as more information becomes available.
Posted Apr 02, 2026 - 17:32 CEST
This incident affected: Earn Dashboard.