DASH Explorer does not have latest blockchain data

Incident Report for Ledger

Resolved

This incident has been resolved.
Posted Nov 10, 2022 - 02:14 CET

Investigating

We have detected a problem with getting latest blockchain data from DASH Explorer. We are checking this incident.
Posted Nov 10, 2022 - 02:05 CET
This incident affected: Ledger Explorers (Dash (DASH)).