Polygon (MATIC) Mainnet Degraded Service
Incident Report for Ledger
Resolved
This incident has been resolved.
Posted Jun 04, 2024 - 16:57 CEST
Investigating
We are experiencing technical issues with the Polygon Mainnet within Ledger Live. This may impact your ability to send transactions, add accounts and view your balances or transaction history. Our team is actively working to resolve the issue. For urgent transactions, please refer to this article for alternative methods.
Posted Jun 04, 2024 - 16:42 CEST
This incident affected: Ledger Explorers (Polygon (MATIC)).