XST explorer API has elevated error rates.
Incident Report for Ledger
Resolved
This incident has been resolved.
Posted Sep 09, 2020 - 07:51 CEST
Investigating
XST explorer API test has failures detected. We are checking this incident.
Posted Sep 09, 2020 - 07:43 CEST
This incident affected: Ledger Explorers (Stealthcoin (XST)).