DOT explorer API has elevated error rates.
Incident Report for Ledger
Resolved
This incident has been resolved.
Posted Jun 10, 2022 - 18:31 CEST
Investigating
DOT explorer API test has failures detected. We are checking this incident.
Posted Jun 10, 2022 - 18:05 CEST
This incident affected: Ledger Explorers (Polkadot (DOT)).