Verification is currently underway for the maintenance items.
Posted Sep 05, 2024 - 17:51 CEST
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 05, 2024 - 17:00 CEST
Scheduled
Please be aware that Cosmos (ATOM) upgrade to version 19.2.0 is scheduled. During the maintenance window your operations (getting transactions and balance updates, sending feature) may be temporary unavailable. We apologize for any inconvenience this may cause and appreciate your understanding as we work to improve our services.
Please follow this notification. It will be closed once the maintenance is completed and the service is fully operational.
Thank you for your continued support and understanding.
Posted Sep 05, 2024 - 15:55 CEST
This scheduled maintenance affected: Ledger Explorers (Cosmos (ATOM)).