Dogecoin (DOGE) Mainnet api does not have the latest blockchain data.
Incident Report for Ledger
Resolved
This incident has been resolved.
Posted Apr 18, 2024 - 11:30 CEST
Investigating
We have detected an issue with fetching the latest blockchain data from Dogecoin (DOGE) Mainnet. This is being investigated by the team.
Posted Apr 17, 2024 - 17:04 CEST
This incident affected: Ledger Explorers (Dogecoin (DOGE)).