ALGO explorer does not have latest blockchain data
Incident Report for Ledger
Resolved
This incident has been resolved.
Posted Jan 20, 2023 - 09:13 CET
Investigating
We have detected a problem with getting latest blockchain data from ALGO explorer. We are checking this incident.
Posted Jan 20, 2023 - 08:47 CET
This incident affected: Ledger Explorers (Algorand (ALGO)).