EGLD Explorer does not have latest blockchain data
Incident Report for Ledger
Resolved
This incident has been resolved.
Posted Jan 09, 2023 - 14:12 CET
Investigating
We have detected a problem with getting latest blockchain data from EGLD Explorer. We are checking this incident.
Posted Jan 09, 2023 - 08:39 CET
This incident affected: Ledger Explorers (Elrond (EGLD)).